Minimum requirement to use LetsBuild - Version iOS & Android

The minimum requirements to use LetsBuild on iOS are the following:

  • iOS 11
  • iPad mini 4 - iPhone 7

For an optimal experience, LetsBuild recommends at least the following configuration:

  • Latest iOS version
  • iPad mini 5 - iPad 7 (2019) - iPad Pro (2018) - iPhone 11 Pro

The minimum requirements to use LetsBuild on Android are the following :

  • Android 5 (Lollipop) *
  • 1 GB of available storage
  • 1 GB of RAM
  • Processor 1 GHZ
  • Wi-Fi 802.11 a/g

For an optimal experience, LetsBuild recommends at least the following configuration:

  • Android 8.0 (Oreo) *
  • 32 GB of storage
  • 2 GB of RAM
  • Multi-core processor > 1.5 Ghz
  • Wi-Fi 802.11 a/b/g/n/ac
  • Flashlight

*Some features are only available for tablet.

Got a problem? Contact our support here or ask your questions online directly on the app!


How did we do?


FAQ (opens in a new tab)

Powered by HelpDocs (opens in a new tab)